[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mozilla M18 on Potato



Sven LUTHER wrote:
On Thu, Oct 26, 2000 at 06:56:38PM -0700, Taro Fukunaga wrote:
> I tried compiling M18 on potato but I got error messages about 
> incompatible gtk+. I have 1.0.x, but M18 requries 1.2.x. But gtk+ 1.2.x 
> is only available for woody, am I right?

False, gtk+1.2 should be availabel in potato since the early mess of having
lots of incompatible gtk+1.1.x packages laying around.

it is named libgtk1.2 and libglib1.2, i think.

Friendly,

Sven LUTHER

I do have gtk+1.2, but when I run the configure script, the configure script runs gtk-config, which reports the older version. I need to somehow force gtk-config to point to the newer libraries.

The output of gtk-config

-L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk -lglib -lXi -lXext -lX11 -lm

My system layout:

lrwxrwxrwx    1 root     root           19 Oct 25 00:48 libgtk-1.2.so.0 -> libgtk-1.2.so.0.5.2
-rw-r--r--    1 root     root      1700232 Feb 22  2000 libgtk-1.2.so.0.5.2
-rw-r--r--    1 root     root      1588722 Jan 25  1999 libgtk.a
lrwxrwxrwx    1 root     root           15 Oct 26 18:46 libgtk.so -> libgtk.so.1.0.6
lrwxrwxrwx    1 root     root           15 Oct 26 18:46 libgtk.so.1 -> libgtk.so.1.0.6
-rw-r--r--    1 root     root       953780 Jan 25  1999 libgtk.so.1.0.6
I think lgtk refers to libgtk.so, am I right?
-- Taro


Reply to: