[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yaboot dual boot problems

On Sat, Sep 09, 2000 at 11:19:35PM -0500, pohl wrote:
> Ethan wrote:
> > 
> > this is ybin 0.16, 0.16 sucks ;-)
> >
> > install 0.21, you can get a deb from http://them.org/~drow/debian
> There was a routing problem between us and them.org (and I was
> impatient to try your suggestion) so I grabbed the tarball for

actually its probably DNS, whoever hosts DNS for dan has a really
misconfigured server.  

> ybin 0.21 off of alaska.net.  Since I wasn't using the deb, I
> didn't have to worry about the .sh extension on the ofboot.b file.
> Other than that, the yaboot.conf file is exactly as you suggested:
> ---------------------------------
> device=hd:
> delay=5
> timeout=50
> magicboot=/boot/ofboot.b
> boot=/dev/hda5
> install=/boot/yaboot
> macos=/dev/hda8
> image=/vmlinux
>         label=linux
>         root=/dev/hda7
>         partition=7
>         read-only
> ---------------------------------
> When installed with mkofboot or ybin, everything appears to go
> fine, with the exception of a warning about nvsetenv being an
> incompatible version.

install the upgraded powerpc-utils to fix that.  (on them.org though,

> Upon reboot, all I get is the flashing question-mark-on-a-folder
> after a pause.  I tried explicitly going into OF and setting
>     setenv boot-device hd:5,\\:tbxi
> then
>     boot
> But it complains:
>    can't OPEN: hd:5,yaboot

i think your OpenFirmware configuration is fscked, or else you you ran
just ybin instead of mkofboot (you need to run mkofboot to make sure
old stuff is erased, alot has changed since 0.16) 

reset your OpenFirmware configuration by holding down command option p
r while cold booting your machine.

> I tried this with the 0.6 yaboot that I was using before, and with
> the 0.7 binary that came in ybin-0.21.tar.gz, with the same result
> each time.

i think your mixing the old ybin stuff with the new version.
(remember /usr/sbin/ybin supercedes /usr/local/sbin/ybin with root's

1) make sure your yaboot.conf magicboot variable points at the NEW
ofboot.b in ybin 0.21 and not the old debian version (check for

2) run /usr/local/sbin/mkofboot -v (type the full path, i assume you
ran make install for ybin 21)

3) shutdown your mac, and hold down command option p r while booting it,
keep these keys down till it reboots itself 3 times.  

let me know how that goes.  

> P.S.  I'm really appreciating the netboot mini-howto, by the way.
> It's a nice safety-net to have that set up.

Ethan Benson

Attachment: pgpcPayjUSq2f.pgp
Description: PGP signature

Reply to: