[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

harddrive troubles with install on G3 powerbook

bhi all,
I'm trying to get debian onto a powerbook G3 laptop, but much has gone
astray.  I don't know exactly which model, but its about 7 months old
and pre-firewire and has an ata ibm drive and a 3d rage lt pro video
To make things interesting, it doesn't have a floppy drive, only cdrom.
So I grabbed the unofficial potato disks from ftp.fsn.hu and tried
them.  Before the install, it had a 2gig mac partition and a 4 gig soon
to be root and a 64meg swap partition and was booting fine to os9.  It
also had 7 other tiny misc partitions that it had set up.  I put in the
cd the first time and everything was appearing to go smoothly.  I
decided to up the swap space, so I changed the last 2 partitions hda9 &
hda10 to 128mg swab on 9 and ~3.9gb on 10 as my root.  Since I wasn't
touching any of the other partitions, I was hoping I wouldn't have to
reinstall os9.  So I went through the install and everything looked
fine, until the reboot.  This is where I'm confused.  I've read that
QUIK doesn't actually finish setting up the boot-device, but didn't find
that out until after...  So anyway, the first reboot went like this:
First the blank white background came up and a short period of periodic
harddrive activity occured.  Then the finder folder came up flashing a ?
(looking for a blessed folder I assume).  Nothing happened after that.
So I put the cd back in and rebooted.  Same thing happened except after
a couple of seconds of the ? folder it booted to the cdrom.  However
right above the yaboot line was
wrong partition 1 signature
I hit enter and then it said:
loading kernel
wrong partition 1 signature
loading ramdisk
wrong partition 1 signature

and then finally booted and started up dbootstrap again.  I was able to
mount the linux partition and all the data that had been installed
before was still there and intact.  I've been looking all over for some
documentation on how to fix this, but nothing has worked.  I've tried
different OF commands to no avail, but I never really understood what I
was doing.  When I tried typing "debian root=/dev/hda10" on the yaboot
line it booted to the harddrive and then pancaked when it got to the
pcmcia modules and rebooted after 180secs.  After some more searching pn
the net, I came back to try some more stuff and I could no longer get it
to boot to the cd-rom.  The same thing occurs as before except when the
kernel is booting it hangs at the hard drive init code:
hda: Enabling MultiWord DMA 2
hda: IBM-DBCA-206480, 6194MB w/420kB Cache, CHS=13424/15/63, (U)DMA
hda: IBM-DBCA-206480, 6194MB w/420kB Cache, CHS=13424/15/63, (U)DMA

Any help or pointers to some good docs would be appreciated.


Reply to: