[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X problems

On 17-Maj-00, you wrote:

> Björn Johansson wrote:
>> I have been trying a lot to get the mouse working under X, but with no
>> luck. GPM is configured to use the mouse, so I know which device it would
>> be configured as.
> You need protocol "busmouse" and device /dev/amigamouse.

Ok, fixed.

>> I have also been experiencing problems with X(Xfree86 3.3.6). After
>> installing a program called: *app.login*(nextstep look) it did something
>> bad with my system(I think), so now I had a nice login window but when I
>> tried to log in, the window closes(accepts the password) and then the
>> login window appears again telling me to login. I have done many
>> reinstallations of the files which could have been damaged, replaced the
>> XF86Config file, even changed XDM to WDM, but nothing seems to work :(.
>> Before the installation of the login.app, XDM worked just fine. Many of
>> the problems I'm having has to do with the fact that I've done a bad
>> installation(it'll do for now). Once Potato get's finished I won't haveto
>> mess around so much with the system all the time, hopefully ;).
>> When running startx, the output doesn't complain about anything(weird!).
>> After opening the display it shuts down, maybe someone got a clue?
> You have to check how login.app starts the actual session and configure
> that to start what you want.

It won't matter how I configure login.app or any other login-program
for that matter, because X won't start at all. It just starts and I can move
the mouse for 1 second or so.

> If it doesn't work, go back to xdm or gdm.
> Michel

Here's what the wdm.log gives:

XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
    If the server is older than 6-12 months, or if your card is newer
    than the above date, look for a newer version before reporting
    problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.15pre10 ppc [ELF] 
Configured drivers:
   FBDev: Server for frame buffer device
   (Patchlevel 11): mfb, afb, cfb8, cfb16, cfb32, NCR 77C32BLT (accel), ATI
Mach64 (accel), IMS TwinTurbo (accel), 3Dlabs Permedia 2 (accel)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: disabled
(**) Mouse: type: busmouse, device: /dev/amigamouse, buttons: 3
(**) Mouse: 3 button emulation (timeout: 50ms)
(**) FBDev: Graphics device ID: "Linux Frame Buffer Device"
(**) FBDev: Monitor ID: "ANITECH"
(**) FontPath set to
(**) FBDev: Using XF86Config video mode database
(--) FBDev: Frame buffer device: Amiga AGA
(--) FBDev: Video memory: 1280K @ 0xbf000
(--) FBDev: MMIO regs: 0K @ (nil)
(--) FBDev: Type 1 type_aux 0 bits_per_pixel 8
(--) FBDev: Hardware accelerator: Amiga Blitter
(--) FBDev: No driver support for hardware acceleration
(--) FBDev: Using afb driver
X connection to :0.0 broken (explicit kill or server shutdown).

MVH  Björn "Bear" Johansson


Reply to: