[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Quik segfaults


I just built a new 2.2.14 kernel package, and installed, but quik

Unfortunately, it is stripped, so all I can get for a backtrace is

(gdb) backtrace
#0  0x10011a3c in ?? ()
#1  0x0 in ?? ()

This is on a StarMax with the latest potato and stock 2.2.13.  I've got
the boot stuff on a zip drive so /boot is linked to /zip/boot, /zip is a
simlink to the automount point /mnt/amnt/zip.  I've confirmed that it's
mounted before using quik.  Could any of this be confusing quik?

(I boot from the zip because Debian is on /dev/hdb, which OF and MockOS
can't see.  Floppy booting adds about a minute to the process.  And
I really don't want to try to resize the HFS partition on /dev/hda...)

/etc/quik.conf is attached, default is the second entry (linux).  (BTW,
the adb_buttons option doesn't work- I get button 2 on the left
alt/option, but can't find button 3.)


      Adam Powell                     http://lyre.mit.edu/~powell/
      Thomas B. King Assistant Professor of Materials Engineering
      77 Massachusetts Ave. Rm. 4-117         Phone (617) 452-2086
      Cambridge, MA 02139 USA                   Fax (617) 253-5418

init-message = "Booting Debian GNU/Linux (Potato)\n"
timeout = 0

image = /boot/vmlinux-2.2.14
	append = "adb_buttons=58,52,107"
	label = offb

image = /boot/vmlinux-2.2.14
	append = "adb_buttons=58,52 video=atyfb:vmode:18"
	label = linux

image = /boot/vmlinux-2.2.13
	append = "video=clgenfb: adb_buttons=58,52"
	label = oldlinux
	alias = l

image = "$bye"
	label = bye

Reply to: