[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: esound = e problems

 Ok, here we are.

 The file permissions of the devices are all fine, as well as the
 owner and the group. I tried again and again, and the result is that
 if the Ethernet cable is plugged in, then esd is started and
 therefore enlightenment is started too. If the Ethernet is not
 plugged it, nothing of the above works. I investigated the thing some
 more, and apparently esd tries to open an unix socket connection.

 Then, I unplagged the Ethernet cable again, and I killed the daemon,
 which was started *somehow* as ``esd -nobeeps''.
- By triggering esd, I heard some bep-bop, but esdplay did not work.
- I tried ``esd -unix'', and still esdplay did not work.
- Then I tried ``esd -tcp'' and by magic esdplay started working.

 1. what starts esd?
 2. how do I modify the thing to use tcp instead of unix sockets?
 3. is that the way, or I have to do something else?
 (Yes, I looked at the esd man page, but it is of no help.)


Reply to: