[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Any suggestions for reviving a hosed bash?

On Mon, Apr 19, 1999 at 02:56:29PM +0300, Konstantinos Margaritis wrote:
> On Sun, 18 Apr 1999, Mr. Christopher F. Miller wrote:
> >On Sat, Apr 17, 2004 at 12:44:14PM -0800, Rob Clark wrote:
> >
> >I found the easiest way was to untar a new base2.tgz 
> >onto a zip, boot on that zip and then mount my hosed system at /mnt.
> >
> >Took a little futzing with fstab.  But I could fdisk, mke2fs, untar
> >and edit on another machine.
> Well, I did a little testing on my own and found that a way not to render
> a machine unusable is the following (assuming bash 2.01.1-4.1 and libreadline 2.1-12
> are installed).
> dpkg -i --force-depends bash_2.02.1-1.4_powerpc.deb bash-builtins_2.02.1-1.4_powerpc.deb
> it needs the force-depends because it needs the new libreadline.
> But, if the libreadline is installed first the older bash does not work and dpkg fails at
> postinst. Te newer bash works fine with the older libreadline.
> After bash has been installed, test it (either login, or run it). Then, you
> may install the libreadline debs:
> dpkg -i libreadlineg2-dbg_2.1-13.2_powerpc.deb \
>         libreadlineg2-dev_2.1-13.2_powerpc.deb \
>         libreadlineg2_2.1-13.2_powerpc.deb
> The reason I did not experience the bash failure was that by pure chance maybe, I chose
> this way to install it. All other combinations/ways I tried, produced effects similar
> to the ones described in the list.
> IMHO, the only safe way to get rid of such critical problems, is to have the
> preinst/postinst scripts use another shell (maybe csh?)
> Until I fix this and release another version, please use this method to upgrade.

I experienced the same problem yesterday, and copying the old libreadlineg2 libs from my second root partition solved the problem.

Are you saying that i can now safely install the new libreadlineg2 packages ?



Reply to: