[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IMPORTANT : latest bash intall fails and bash is no more usable!!!

>>>>> "VALETTE" == VALETTE Eric <valette@crf.canon.fr> writes:

VALETTE> I updated two debianppc system this morning and the last bash 
VALETTE> version is bugged!!! (install failed...)

VALETTE> As a result, you cannot do su anymore which is a pain to update
VALETTE> the system again. People not having other shell installed may be 
VALETTE> deadlocked!!!

VALETTE> I also use this mail to remember that the pdksh distributed is bogus
VALETTE> I have a working binary that I can upload anywhere...

VALETTE> I add to do :
VALETTE>   1) su --shell=/usr/bin/ksh
VALETTE>   2) mv /bin/bash /bin/bash.bug
VALETTE>   3) ln -s /usr/bin/ksh /bin/bash

Anwser to myself : in fact the package themseleves are not bugged
but the update procedure via dselect...

I did after renaming ksh to bash

  1) cd /var/lib/dpkg/methods/ftp/debian/dists/unstable/main/binary-powerpc/base
  2) dpkg -i bash_2.02.1-1.4.deb                                                               <
(Reading database ... 21767 files and directories currently installed.)
Preparing to replace bash 2.01.1-4.1 (using bash_2.02.1-1.4.deb) ...
/var/lib/dpkg/info/bash.prerm: /home/valette/.kshrc[25]: bind: cannot bind, not a tty
/var/lib/dpkg/info/bash.prerm: /home/valette/.kshrc[26]: bind: cannot bind, not a tty
/var/lib/dpkg/tmp.ci/preinst: /home/valette/.kshrc[25]: bind: cannot bind, not a tty
/var/lib/dpkg/tmp.ci/preinst: /home/valette/.kshrc[26]: bind: cannot bind, not a tty
Unpacking replacement bash ...
Setting up bash (2.02.1-1.4) ...

  /  `                   	Eric Valette
 /--   __  o _.          	Canon CRF
(___, / (_(_(__         	Rue de la touche lambert
				35517 Cesson-Sevigne  Cedex
Tel: +33 (0)2 99 87 68 91	Fax: +33 (0)2 99 84 11 30
E-mail: valette@crf.canon.fr

Reply to: