[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

iMac installation


I have been trying to install Debian on an iMac, and I have reached a
sticking point. Here is a summary of what I have done thus far. If anyone
could help me to finish, I would appreciate it.

I first installed LinuxPPC on its own partition. One I had this installed,
I unziped base2_2.tgz onto a different partition. I edited /etc/fstab,
/etc/init.d/network, /etc/hostname, and /etc/resolv.conf . Using BootX 1.0.2
I was able to boot this distribution, and start up single user mode.

I have a ppp dialup connection, so I would like to install the new versions
of the packages, so that I can have X, etc. However, I am having a problem 
getting this to work. I ran pppconfig (although I am unsure which device
corresponds to the internal modem). But when I run pon, I get a message 
saying that the kernel doesn't support ppp. When I run dmesg, one of the 
messages from the kernel mentions ppp. I started up the modules script in
/etc/init.d. Hoping to fix this problem, I downloaded a new version of the 
LinuxPPC kernel, a 2.2.1 release. Ran the same modules script. It complains
that it can't find char-major-4 (I tried an alias in the modules.conf file,
but it complained, and there already is one in the /etc/modules/aliases file).
So I tried manually installing kernel-image-2.2.1-pmac_2.2.1-1.deb, both in
debian and on the Mac partition so that I could use BootX. But this kernel
doesn't seem to recognize USB devices (including the keyboard), so it is

Any suggestions?

Matthew J. Kraai  Senior, Computer Science, Carnegie Mellon University

Freedom is not free.

Reply to: