[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X and gtk problems ...

On Wed, Dec 02, 1998 at 10:05:14AM -0500, Daniel Jacobowitz wrote:
> On Wed, Dec 02, 1998 at 03:28:26PM +0100, Sven LUTHER wrote:
> > Hello, ...
> > 
> > i have been playing with the libgtk and libglib packages yesterday, and have
> > problems with it.
> > 
> > the current packages are libglib1.1.4 and libgtk1.1.2, and i was unable to
> > compile some test programs with this two, the linker complained about some
> > inexistent symbol in glib and something about dlopen@GLIBC2.0 so i got the
> > source from this package i got on my local mirror (only libglib 1.1.3 and
> > libgtk1.1.2) compiled them installed them, and my compile problem went away,
> > but the resulting program hangs with :
> This is a known issue with different glibc versions.  The libraries
> will continue to _work_ under different glibcs than they were built
> with, but must be recompiled in many cases to be able to build new
> programs.
> > Gdk-Message: 
> > ** ERROR **: sigsegv caught
> > 
> > not very meaningful.
> > 
> > did somone manage to compile and run gtk programs on debian/ppc ? should i get
> > the latest libglib ? (there are some endian things in the CHANGES for the
> > latest version ?).
> Some (many) GTK apps will do this if not started from gnome-panel.  I
> have got at least eeyes working locally, so not all is lost.

even a simple ¨hello_world" program taken from the gtk-tutorial ? also my
program (self made, no gnome stuff in it) worked on my gnome-less solaris box.
(altough i had problems when upgrading to glib/gtk 1.1.5, but strangely these
 didn't disapear when installing the previous glib/gtk again ...)
> > 
> > ok about the xterm problems i had, i did a strace, and it was a permission
> > problem when opening /dev/tty. my /dev/tty is from an earlier base tarball, but
> > i think that i ran MAKEDEV on it. anyway it shows the following permisions :
> > 
> > rw-r--r--, so i chmoded that, and it worked fine, but a when i tried to open a
> > second xterm, i got a :no more free /dev/tty" or something similar, any idea
> > what is wrong here ?
> Send me an strace of the second one, then.  Something is going wrong.

ok i will look at it, but then i just was told that i should use the p option
when untaring the base tarball, so this could be the cause of it, but MAKEDEV
should recreate the devices with the correct permissions, or shouldn't he ?

it is ok if i look at the strace and just tell you the problem, or do you need
it, it is quite big ?

> > also when i installed the server, and asked to put in the packages XF86Config,
> > it tried to parse the existing XF86Config, and complained about Device "fbdev".
> > so i stopped the upgrade, and just left the old XF86Config in place. Is this a
> > Bug ?
> Yes, but I'm not really looking at X bugs until 3.3.3 is in place, and
> even then perhaps not for a month.  It's the week before final exams,
> and then break.

maybe i could have a look at it, if i have some time. But i am fairly ignorant
as to the internals of Xfree ...



Reply to: