[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X and gtk problems ...

Hello, ...

i have been playing with the libgtk and libglib packages yesterday, and have
problems with it.

the current packages are libglib1.1.4 and libgtk1.1.2, and i was unable to
compile some test programs with this two, the linker complained about some
inexistent symbol in glib and something about dlopen@GLIBC2.0 so i got the
source from this package i got on my local mirror (only libglib 1.1.3 and
libgtk1.1.2) compiled them installed them, and my compile problem went away,
but the resulting program hangs with :

** ERROR **: sigsegv caught

not very meaningful.

did somone manage to compile and run gtk programs on debian/ppc ? should i get
the latest libglib ? (there are some endian things in the CHANGES for the
latest version ?).

ok about the xterm problems i had, i did a strace, and it was a permission
problem when opening /dev/tty. my /dev/tty is from an earlier base tarball, but
i think that i ran MAKEDEV on it. anyway it shows the following permisions :

rw-r--r--, so i chmoded that, and it worked fine, but a when i tried to open a
second xterm, i got a :no more free /dev/tty" or something similar, any idea
what is wrong here ?

also when i installed the server, and asked to put in the packages XF86Config,
it tried to parse the existing XF86Config, and complained about Device "fbdev".
so i stopped the upgrade, and just left the old XF86Config in place. Is this a
Bug ?



Reply to: