[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fakeroot segfaults when running dbuild-rfakeroot.

There are two fakeroots.  libtricks' simply does not work (segfaults). 
Fakeroot - well, do NOT use fakeroot!  It forks three processes when
used; one of them on powerpc goes into an endless loop and starts
eating swap and CPU.


On Wed, Oct 28, 1998 at 12:43:35PM +0100, luther@maxime.u-strasbg.fr wrote:
> Hello, ...
> i have tried building some packages with dbuild, but with various success.
> dbuild -rfakeroot, had big problems, because fakeroot segfaulted. i think this
> is due to the fact that fakeroot is from december 12, 1997, and thus surely not
> compiled with the current glibc, and i think i read something about fakeroot
> needing to be the same glibc2 as the installed one.
> dbuild -rsudo compiled correctly, but had a problem later on saying it didn't
> find a library (actually a symlink) that was there, i think it is a access
> right problem.
> (i tried dpkg-buildpackage -rsudo with the same result).
> a dpkg-buildpackage ªs root built the package correctly, but i didn't tried
> dbuild as root yet.
> Friendly,
> ~                                                                               
> ~                         
> --  
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: