[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Status of Debian on the PowerMacs?

cfm@maine.com wrote:
> I've just reinstalled debian from the base.tar.gz tarball.
> I had (have) three difficulties: 1) relating to the tarball 2)
> another because I was installing **over** a redhat/mklinux
> system, and 3) no editor worked.
> 1)  dselect/dpkg uses awk to determine diskspace available.
> My awk was a mess of back and forth symlinks ultimately pointing
> to gawk, which because of glibc2 would only segfault, hence
> no disk space available, hence deselect failed.

This is a known bug which has been addressed.  The base system
currently lacks an awk.  Hartmut will include one in the next
base tarball.

> 2) I had a bunch of shell-utils, chown, chmod, etc... in path
> built with incompatible libs.  Had to blow them away.

Did you try to reinstall the shellutils.deb?

This libc is incompatible with most of all libc's for PowerPC
before.  You cannot run old binaries with the new libc.[1]

> 3) vi /etc/inittab (or any file) would only give me an empty screen.
> I've not figured that one out yet.

Did you try to install a different editor?

Check your TERM, LINES and COLUMNS variables.  I know from other
systems that they mess up with my screen modes.

> It may or may not be a difficulty, but I've still to figure out
> just how to convert a running system to debian without blowing

Since the libraries this is difficult.  We tried this, I believe these
trials did cost us at least half of a year - together with endless
compilations of new and old C libraries, compatibility packages,
screwing the system etc.

> everything away.  I have difficulties `bootstrapping' dpkg.  Apt
> seems easier, but I did not find an apt-get for powerpc.

Try to compile it on your own.  If it's not in main but in experimental
it won't be compiled regularily.

> > I've included a prelimnary installation document in my powerpc web
> > pages at http://master.debian.org/~joey/powerpc/install.html.
> > 
> > I need more information in order to complete it.  I'd appreciate
> > if the people who recently have installed the system would send
> > me appropriate paragraphs.

[1] You can still run them, there is a bincompat package/program/library,
    but it didn't work as expected.



*** Fatal Error: Found [MS-Windows], repartitioning Disk for Linux ...

Reply to: