[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sparc autocompile



(I'm cc'ing this to debian-powerpc, since they are having the
same problems)

Previously Johnie Ingram wrote:
> Actually, because of various glitches, the large number of
> uncompilable packages after all these months, and the LCS's focus on
> standardizing the 2.0.7t interface, I'm starting to doubt the benefits
> of using glibc 2.1.

LCS should not focus in 2.0.7t I think. We will switch to 2.1 when it
arrives, and it would be a shame if that immediately obsoletes the LCS.

> Plus our glibc2.1 debs are incompatible with all the redhat/sparc and
> ultrapenguin systems already out there, which is making the ultra port
> difficult.

I'm somewhat concered about 2.1 as well: it seems to break a lot of
programs since it changes a bunch of includes and the kernel-interface.

The real problem is that we use 2.0.7t on the i386, so that is what
most programmers/developers/maintainers see. But for some ports (ppc,
ultrasparc) we need 2.1 since 2.0 does not support these architectures.
This means that people doing the porting will have a lot more work on
their hands..

Ideally we should put an i386 glibc 2.1 in experimental and encourage
maintainers to try their packages with that.

Wichert.

-- 
==============================================================================
This combination of bytes forms a message written to you by Wichert Akkerman.
E-Mail: wakkerma@wi.LeidenUniv.nl
WWW: http://www.wi.leidenuniv.nl/~wichert/

Attachment: pgpeDci2fwWKp.pgp
Description: PGP signature


Reply to: