[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#403649: debian-policy: Should clarify package availability in "postrm remove"

forcemerge 504880 403649

Hi Frank,

Frank Küster wrote:

> Current Policy says:
> ,---- 7.2 Binary Dependencies
> | The Depends field should also be used if the postinst, prerm or
> | postrm scripts require the package to be present in order to
> | run. Note, however, that the postrm cannot rely on any
> | non-essential packages to be present during the purge phase.
> `----
> I suggest to add to the second sentence: ", and that only the postinst 
> script can rely on the package to be configured."

Does the patch in [1] look reasonable?


[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=351;bug=504880

Reply to: