[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#111025: debian-policy: typo in chapter 9: ldconfig and pre/post scripts



On Tue, Sep 04, 2001 at 08:53:20PM -0400, Steve M. Robbins wrote:
> Perhaps the intention of the section 9 paragraph (above) was to
> say
> 
> 	However, the postrm script must not call ldconfig if invoked
> 	with the argument "upgrade", "failed-upgrade", or "disappear".
> 	The preinst script must not call ldconfig if invoked with
> 	the argument "abort-upgrade".
> 
> However, that is a bit longwinded and fairly confusing.

It seems neither to me.  The fact that a lot of maintainers are likely
ignorant of the details of maintainer script invocation (this isn't a
rip on other developers -- I personally went for far longer than I
should I have without a good understanding of what is now Policy 6.5)
may make it seem that way, but I see nothing wrong with the language
above.

-- 
G. Branden Robinson                |
Debian GNU/Linux                   |      If encryption is outlawed, only
branden@debian.org                 |      outlaws will @goH7Ok=<q4fDj]Kz?.
http://people.debian.org/~branden/ |

Attachment: pgpsgSUJL6FSf.pgp
Description: PGP signature


Reply to: