[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid

On Sun, Jun 10, 2012 at 06:54:43PM +0100, Dominic Hargreaves wrote:
> I've requested removal of libtime-piece-perl[0] and libparent-perl[1],
> which are the only packages currently uninstallable due to be being
> dual-lived, as far as I can see.
> The rest of the packages at
> <http://lintian.debian.org/tags/package-superseded-by-perl.html>, currently:
> libextutils-command-perl
> liblocale-maketext-simple-perl
> libperl-ostype-perl
> libtest-simple-perl
> libthread-queue-perl
> libtime-local-perl
> are redundant, because they have the same version as perl, but they
> are installable, so they are not really the subject of this bug.
> Therefore I'm closing this one now.
> Note: before many of the above lintian warnings can be fixed, the 
> warnings from
> <http://lintian.debian.org/tags/versioned-dependency-satisfied-by-perl.html>
> need to be fixed.

In fact, this only applies to libtest-simple-perl; the other packages
do not have versioned depends on them. Therefore I propose we request
the removal of the following (I've checked that none of them have
newer upstream versions):


Any objections?

Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

Reply to: