[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How to handle dependence in control file


I've created a debian package of Tie::IxHash (for my own use)
and don't know how to handle the dependence in the control

The module Tie::IxHash requires Perl >= 5.003. I don't want
to make this module depend on `perl-5.005', but just `perl5'
wouldn't be restrictive enough. My current `Depends:' line looks
like this:

Depends: ${perl:Depends}

This line expands to

Depends: perl5

How can I make the package depend on any perl distribution greater
or equal to 5.003 (instead of greater or equal to 5.000)?


Daniel Lutz

Say NO to HTML in mail and news.

GnuPG: 1024D/14E06AAF (public key available on any keyserver)

Reply to: