[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#422937: marked as done (Spell checking not working)

Your message dated Wed, 9 May 2007 23:05:49 +0200
with message-id <20070509210549.GA27103@rene-engelhard.de>
and subject line Bug#422937: Spell checking not working
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: openoffice.org-dictionaries
Version: 1:

	I'm using a standard installation of OpenOffice on
stable/etch, and my spellchecking is no longer working. I've upgraded
recently to etch from sarge, and I don't remember is the spell check
was working post upgrade or not.

	You may think that it's the trivial issue of not having the
proper language set in the paragraph style. Well, it's not.
	This is what I do in Writer :
		o create a new Text document.
		o type random characters
		o select the text
		o context menu -> Characters
		o Language is set to "English USA"
		o Tools->Spellcheck
		o "The spellcheck is complete".
		o Text it not corrected.

	Note that after noticing the problem, the first thing I did
was to delete the ~/.office* directories. This did not help.

	These are random observations leading me to believe that
this is not an usual problem.
	In the Character->Language selection pulldown, I remember that
all languages with a dictionaty installed had a ABC tickmark icon in front
of them. On my install, none of them has that.
	The title of the spellcheck windows has the following title :
		"Spellcheck: ()"
	The Wizards->Install new dictionaries does not do anything at all.
	In Tools->Options->LanguageSettings->WritingAids, the list of
"Available language module" is empty.
	Tools->Language->Thesaurus is grayed out.
	Tools->Language->Hyphenation returned an error the first time
I ran it that it could not find US/GB stuff. Later, it just does nothing.

	A few details on my system.
	I'm not using Gnome or KDE, but fvwm2.
	My locales :
# ls /usr/lib/openoffice/share/wordbook
en-GB/  en-US/  fr/  it/
# ll /usr/lib/openoffice/share/wordbook/en-US/
total 16
drwxr-xr-x 2 root root 4096 2007-04-20 13:20 ./
drwxr-xr-x 6 root root 4096 2007-05-08 14:02 ../
-rw-r--r-- 1 root root   77 2007-03-22 03:38 Debian.dic
-rw-r--r-- 1 root root  786 2007-03-22 03:38 soffice.dic
# ls /usr/share/myspell/dicts/
DicOOo.sxw       en_GB.dic   en_US.dic   it_IT.aff   th_en_US_v2.dat
dictionary.lst@  en-GB.dic@  en-US.dic@  it-IT.aff@  th_en_US_v2.idx
en_GB.aff        en_US.aff   fr.aff      it_IT.dic   th_it_IT_v2.dat
en-GB.aff@       en-US.aff@  fr.dic      it-IT.dic@  th_it_IT_v2.idx
# cat /etc/openoffice/dictionary.lst
DICT en GB en_GB
DICT en US en_US
DICT fr FR fr
DICT fr BE fr
DICT fr CA fr
DICT it IT it_IT
THES en US th_en_US_v2
THES en GB th_en_US_v2
THES it IT th_it_IT_v2
# dpkg -l \*openoffice\* | grep '^ii'
ii  openoffice.org                       2.0.4.dfsg.2-5etch1 OpenOffice.org Office suite version 2.0
ii  openoffice.org-base                  2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - database
ii  openoffice.org-calc                  2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - spreadsheet
ii  openoffice.org-common                2.0.4.dfsg.2-5etch1 OpenOffice.org office suite architecture ind
ii  openoffice.org-core                  2.0.4.dfsg.2-5etch1 OpenOffice.org office suite architecture dep
ii  openoffice.org-draw                  2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - drawing
ii  openoffice.org-gcj                   2.0.4.dfsg.2-5etch1 OpenOffice.orgs Java libraries (native for u
ii  openoffice.org-help-en-us            2.0.4.dfsg.2-5etch1 English_american help for OpenOffice.org
ii  openoffice.org-impress               2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - presentation
ii  openoffice.org-java-common           2.0.4.dfsg.2-5etch1 OpenOffice.org office suite Java support arc
ii  openoffice.org-l10n-en-gb            2.0.4.dfsg.2-5etch1 English_british language package for OpenOff
ii  openoffice.org-l10n-fr               2.0.4.dfsg.2-5etch1 French language package for OpenOffice.org
ii  openoffice.org-l10n-it               2.0.4.dfsg.2-5etch1 Italian language package for OpenOffice.org
ii  openoffice.org-math                  2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - equation edito
ii  openoffice.org-thesaurus-en-us       2.0.4~rc1-3         English Thesaurus for OpenOffice.org
ii  openoffice.org-thesaurus-it          0+20050726          Italian Thesaurus for OpenOffice.org 2
ii  openoffice.org-writer                2.0.4.dfsg.2-5etch1 OpenOffice.org office suite - word processor
# dpkg -l \*spell\* | grep '^ii'
ii  aspell                          0.60.4-4           GNU Aspell spell-checker
ii  aspell-en                       6.0-0-5.1          English dictionary for GNU Aspell
ii  aspell-fr                       0.50-3-6           French dictionary for aspell
ii  aspell-it                       0.60.20060723ds1-1 The Italian dictionary for GNU Aspell
ii  ispell                       International Ispell (an interactive spellin
ii  libaspell15                     0.60.4-4           GNU Aspell spell-checker runtime library
ii  libmyspell3c2                   3.1-18             MySpell spellchecking library
ii  myspell-en-gb                   2.0.4~rc1-3        English_british dictionary for myspell
ii  myspell-en-us                   2.0.4~rc1-3        English_american dictionary for myspell
ii  myspell-fr-gut                  1.0-18             The French dictionary for myspell (GUTenberg
ii  myspell-it                      2.0.4~rc1-3        Italian dictionary for myspell
ii  spell                           1.0-17             GNU Spell, a clone of Unix `spell'
# dpkg -l \*americ\* | grep '^ii'
ii  iamerican                             An American English dictionary for ispell
ii  wamerican                                    6-2            American English dictionary words for /usr/s
# dpkg -l \*brit\* | grep '^ii'
ii  ibritish   A British English dictionary for ispell
ii  wbritish       6-2            British English dictionary words for /usr/sh

	Yeah, I guess you must now be quite puzzled. Well, good luck...


--- End Message ---
--- Begin Message ---
Jean Tourrilhes wrote:
> >[...]
> > wrong, unrelevant dir. This one here is important, though:
> > 
> > $ dpkg -L openoffice.org-common | grep dict
> > /usr/lib/openoffice/share/dict
> > /usr/share/myspell/dicts
> > /usr/share/myspell/dicts/DicOOo.sxw
> > /usr/lib/openoffice/share/dict/ooo
> > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> > /usr/share/myspell/dicts/dictionary.lst
> > 
> > $ ls -l /usr/lib/openoffice/share/dict/ooo
> > lrwxrwxrwx 1 root root 31 2007-04-10 09:23 /usr/lib/openoffice/share/dict/ooo -> ../../../../share/myspell/dicts
> > 
> > Do you have that? (If not, i've no idea why it got lost as it *is* in
> > the package)
> #  dpkg -L openoffice.org-common | grep dict
> /usr/share/myspell/dicts
> /usr/share/myspell/dicts/DicOOo.sxw
> /usr/lib/openoffice/share/dict/ooo
> /usr/share/myspell/dicts/dictionary.lst
> # ls -l /usr/lib/openoffice/share/dict/ooo
> total 4
> -rw-r--r-- 1 root root 88 2007-05-08 14:27 dictionary.lst
> # ls -l /usr/lib/openoffice/share/dict    
> total 4
> drwxr-xr-x 2 root root 4096 2007-05-08 14:27 ooo/
> 	Thanks. I think I can see the problem.
> 	I've fixed the symlink and it's all working now.

The interesting point here is that this symlink is even in sarges OOo
package. (But indeed some versions during sarge development had problems
with this link, as we moved the myspell dictionaries from there to

And an upgrade to etch doesn't break that link (just tried it in a clean
chroot with openoffice.org, openoffice.org-help-de,
openoffice.org-l10n-de, myspell-de-de installed).

For these reasons, I am closing this bug since it's not a bug in the
packages at all.


 .''`.  Ren�ngelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: