[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#393724: marked as done (openoffice.org: Opens OO.o Writer files read-only)

Your message dated Tue, 17 Oct 2006 18:36:56 +0200
with message-id <200610171836.56482.rene@debian.org>
and subject line Bug#393724: [Solved] openoffice.org: Opens OO.o Writer files read-only
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: openoffice.org
Version: 2.0.4-1
Severity: important

Some files created with OpenOffice.org Writer 2.0.4~rc versions are
opened read-only by OpenOffice.org 2.0.4. Sorry, I don't know the exact
rc version, but I do have a sample file I can share, if needed. 

I have tried opening them with Abiword and saving them to a different
location, but OO.o still opens them read-only. I have confirmed that
they are not open anywhere, and I have even wiped out the
~/.openoffice.org2 dir - all to no avail. It is pretty frustrating to
need to open a file and edit it, only to have to copy/paste it to a new
file before being able to edit it. Especially when it is a file created
by a different version of the same exact software.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (900, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-1-k7
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages openoffice.org depends on:
ii  openoffice.org-base           2.0.4-1    OpenOffice.org office suite - data
ii  openoffice.org-calc           2.0.4-1    OpenOffice.org office suite - spre
ii  openoffice.org-core           2.0.4-1    OpenOffice.org office suite archit
ii  openoffice.org-draw           2.0.4-1    OpenOffice.org office suite - draw
ii  openoffice.org-impress        2.0.4-1    OpenOffice.org office suite - pres
ii  openoffice.org-java-common    2.0.4-1    OpenOffice.org office suite Java s
ii  openoffice.org-math           2.0.4-1    OpenOffice.org office suite - equa
ii  openoffice.org-writer         2.0.4-1    OpenOffice.org office suite - word

openoffice.org recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---

Am Dienstag, 17. Oktober 2006 18:32 schrieben Sie:
> Yes, both files are accessed with nfs. It appears one of my upgrades on
> unstable uninstalled nfs-common, so rpc.statd was not running. An
> apt-get install nfs-common seems to have fixed the read-only problem. 

Thanks. Closing the bug then.

> What does rpc.statd do for OO.org that it can only open files rw when
> statd is running? 

Not for OOo, but for nfs. Like stuff needed for locking, afaik.
And of course without proper locking you get the document ro :)


 .''`.  René Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73

--- End Message ---

Reply to: