[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting openoffice.org-voikko into sid

On Fri, 6 Oct 2006, Rene Engelhard wrote:

1. I built on powerpc; and generate_dependencies.sh hardcodes Linux_x86/
 which of course doesn't work on 1i386. Linux*/* works.

Yes, this is now fixed.

2. you do not need to specify the openoffice.org-core dependency
 manually; OOo has a .shlibs with a conservative value (upstream
 version). Unfortunately they just get picked up when setting
 LD_LIBRARY_PATH appropriately.

Changed that, thank you.

3. It doesn't seem to work at all (at least on ppc); Suomi/suomi (which I
  understand is a right word) get underlined but with no way to get a
  correction. Neither does it work when breaking it into Sumoi or so.
  I just get the "normal" context menu.

This apparently is because of ppc is big endian, and suomi-malaga only installed voikko-fi_FI.*_l files. This should be now corrected in http://mentors.debian.net/debian/pool/main/s/suomi-malaga/suomi-malaga_0.7.2-4.dsc
though I cannot test it as I unfortunately don't have a ppc machine.

That package would now need sponsoring again, too.

  If it really only works on i386 yet, please restrict Architecture: to

Let's if it starts working on ppc with these fixes. I've tested it on i386 and amd64 myself so far.

  That's why I suggested at soikko to Recommend the modules; can you
  take soikkos Recommends: for voikko, too?

Done! The new openoffice.org-voikko package is at:


Reply to: