[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble installing woody OpenOffice deb

On Fri, Feb 28, 2003 at 05:58:05PM -0800, Dan Kegel wrote:
> > I'll write to the mirror maintainer.
> the uninett.no mirror is also out of date.

I also wrote to the maintainer and he has fixed it.

> I grabbed the latest version from
> http://ftp.freenet.de/pub/ftp.vpn-junkies.de/openoffice/ woody main contrib
> and did get 1.0.2.  Sadly, it doesn't solve my display problem.
> Interestingly, I have two computers set up as Debian 3.0 machines,
> and if I remote log in from the other workstation, it displays fine!
> So perhaps it's an X thing?

It is a problem with a broken font somewhere on your font path.  OOo 1.0.x
is overly sensitive to such fonts - this section of the README describes how
to work around it:

No menus are visible
If you cannot see any menus when you start OOo, there are two possible causes.

 1. Zero height.  There is a screenshot attached to the upstream bug report,
    Issuezilla #1872, which you can view here:


 This bug is caused by OpenOffice.org selecting a font that appears to be
 available on your system but cannot be displayed by the freetype library.
 This could be caused by fonts.dir indexes that describe a font file which does
 not exist, read only font files or by a 'broken' font that cannot be displayed
 for some other reason.  It is fixed in the 1.1 branch, but must be worked
 around by removing the problem font from the font path for now.

> The other Debian machine, by the way, can't install the openoffice deb at
> all; it complains (probably because I used some unstable packages at
> some point in the past):
>   openoffice.org: Depends: openoffice.org-bin (> 1.0.1-pre1.0.2) but it is 
>   not going to be installed
> E: Sorry, broken packages

This will be because your libfreetype6 is not the Woody version.  Newer
versions of the library do not work properly with binaries compiled against
an earlier version of the library, so the packages conflict.  You need to
downgrade your libfreetype6 to the Woody version (2.0.9-1).


Reply to: