[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

OpenOffice 1.0.2 crashing on setup. Backtrace attached.

I'm running debian stable, and it's fairly up to date
(I just did apt-get update; apt-get upgrade).

Here's what's happening: I downloaded
I successfully run
   ./install --prefix=/opt
as directed by
Then as a normal user, I did
   cd /opt/OpenOffice.org1.0.2
This flickered the screen, then printed out

OK, I've searched the archives, and saw the mention
about bad fonts possibly causing setup to crash, but
after pulling out the last two fonts, it seems clear
that the crash is after the fonts are finished loading.

I've had the crash with both KDE
and a totally minimal window manager + fspanel.

I tried using the old gnu backtracer as follows:
export LD_PRELOAD=/lib/libSegFault.so
export SEGFAULT_OUTPUT_NAME=/tmp/crash.log
cd /opt/OpenOffice.org1.0.2
but I had to ctrl-alt-backspace, as the program
hung while it was displaying a white splash screen.
/tmp/crash.log only contained a register dump.
Oh, well, I should figure out what's wrong with libSegFault
sometime. (Maybe I didn't wait long enough.)

I then tried ssh'ing in from another machine and setting DISPLAY=:0.0 by
hand, then running the setup binary under gdb.  That worked,
though there was about a ten second delay from saying 'run' to
when the error popped up.
Here's the backtrace:
+ gdb /opt/OpenOffice.org1.0.2/program/setup.bin
GNU gdb 2002-04-01-cvs
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-linux"...
(gdb) run
Starting program: /opt/OpenOffice.org1.0.2/program/setup.bin
[New Thread 1024 (LWP 22309)]

Program received signal SIGABRT, Aborted.
[Switching to Thread 1024 (LWP 22309)]
0x4121e581 in kill () from /lib/libc.so.6
(gdb) bt
#0  0x4121e581 in kill () from /lib/libc.so.6
#1  0x4109494e in pthread_kill () from /lib/libpthread.so.0
#2  0x41094e29 in raise () from /lib/libpthread.so.0
#3  0x4121f8d1 in abort () from /lib/libc.so.6
#4  0x4061b6e5 in SalXLib::XError(_XDisplay*, XErrorEvent*) ()
   from ./libvcl641li.so
#5  0x4061ab6d in sal_XErrorHdl () from ./libvcl641li.so
#6  0x40fb89cd in _XError () from /usr/X11R6/lib/libX11.so.6
#7  0x40fb5ec9 in _XEventsQueued () from /usr/X11R6/lib/libX11.so.6
#8  0x40faa85a in XEventsQueued () from /usr/X11R6/lib/libX11.so.6
#9  0x4061ce89 in DisplayQueue(int, SalDisplay*) () from ./libvcl641li.so
#10 0x4061bc61 in SalXLib::Yield(unsigned char) () from ./libvcl641li.so
#11 0x4062432c in SalInstance::Yield(unsigned char) () from ./libvcl641li.so
#12 0x404b79c1 in Application::Reschedule() () from ./libvcl641li.so
#13 0x40ee3321 in SiParser::ParseScript() () from ./libset641li.so
#14 0x40ee4505 in SiCompiler::CompileTo(SiCompiledScript*, int) ()
   from ./libset641li.so
#15 0x08060bdb in SetupApp::ReadScript(SiDirEntry const&, SiCompiledScript*) ()
#16 0x08060769 in SetupApp::ReadScript(SiDirEntry const&) ()
#17 0x0805ea97 in SetupApp::FindAndReadScript() ()
#18 0x08059427 in SetupApp::Main() ()
#19 0x080616b0 in sal_main ()
#20 0x0806168e in main ()
#21 0x4120e0bf in __libc_start_main () from /lib/libc.so.6

Anyone seen this before?  I suppose I should take this up with
the main openoffice list, but thought I'd mention it here
just in case.

- Dan

Reply to: