[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OCaml 3.09 bug

On Mon, Dec 12, 2005 at 07:35:44PM +0100, Thomas Petazzoni wrote:
> Hi,
> On Mon, 12 Dec 2005 09:36:22 +0100
> Thomas Petazzoni <thomas.petazzoni@enix.org> wrote:
> > Oops, I should have read your message more carefully yesterday
> > evening. I didn't read this PS, so I started to recompile OCaml, but
> > I was too tired to wait until it finishes. More to come tonight, so.
> > I hope it'll fix the issue, so that we will finally be able to upload
> > cduce, camlgz and camlrpc.
> Okay, I just installed the patched OCaml provided by Samuel, and tried
> to compile CDuce with it. However, as suggested by Serge, everything
> needs to be recompiled:
> Build cduce
> Files /usr/lib/ocaml/3.09.0/ulex/ulexing.cmxa
> and /usr/lib/ocaml/3.09.0/stdlib.cmxa
> make inconsistent assumptions over implementation Char
> I could recompile ulex, then something else, and so on. But it's a
> never-ending task, considering the huge number of dependencies my
> application (demexp) has.
> On IRC, Samuel suggests that we should maybe wait until 3.09.1, and if
> I understand correctly, do a complete reupload.
> What do you think about it ?

Just get the complete build-depend tree (he subtree affecting ocaml at least)
and once we have a fix for this issue, we simply ask for binNMUs of all the
involved packages. A new upload is way overkill for this issue.


Sven Luther

Reply to: