[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#320779: ocaml :cannot upgrade

On Tue, Aug 02, 2005 at 10:12:42AM +0200, Stefano Zacchiroli wrote:
> On Tue, Aug 02, 2005 at 06:42:44AM +0200, Sven Luther wrote:
> > Mmm, what did you upgrade from ? 
> > 
> > Stefano, maybe the right answer would be to have a strict version dependency
> > between the different ocaml packages ? a ocaml -> deends ocml'base (==version)
> > or something such ?
> I don't see the problem, the version he tried to upgrade add the problem
> that ocaml could be upgraded without upgrading ocaml-base-nox and thus
> triggered the bug at postinst time.
> The version I uploaded yesterday had not this problem since it has the
> strict dependency on ocaml-base-nox you talk about (assuming ocaml-base
> is a typo in your text above). Trying to upgrade such a version would
> have either forcebly installed the newer ocaml-base-nox or stopped with
> an error stating that installing ocaml-base-nox was necessary (don't
> know the exact semantics of apt). AFAICT dependencies are fine now with
> ocaml 3.08.3-6.

I mean that it would be a good idea to enforce that all the versions of ocaml
parts installed come from the same version, if i remember well, this was the
case when we only had ocaml and ocaml-base.


Sven Luther

Reply to: