[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#320779: ocaml :cannot upgrade

On Mon, Aug 01, 2005 at 05:13:21PM +0200, Stefano Zacchiroli wrote:
> On Mon, Aug 01, 2005 at 04:57:34PM +0200, Sven Luther wrote:
> > > Sven, do you agree on adding the dependency from ocaml directly to
> > > ocaml-base-nox (>= 3.08.3-5)? This should fix the problem.
> > In addition to the normal ocaml-base-nox-3.08.3, yes. And for any package that
> > uses ocaml-md5sum.
> ocaml does not depend directly on ocaml-base-nox-3.08.3, but only on
> ocaml-base..., I'm proposing to add the direct dependency with an
> explicit version which mandate the presence of ocaml-md5sums.
> > We can drop this dependency on the next rebuild.
> Well, no, that dependency should last as long as the ocaml postinst
> invokes ocaml-md5sums

but in the next full rebuild (3.09 or 3.08.4), the ocaml-base-nox-<version>
will be enough and you don't need the versioned dependency anymore.

I am still wondering about what emacsen has to do with ocaml-base-nox though.


Sven Luther

Reply to: