[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lablgtk 1.2.3 META file not up to date



Sven <luther@dpt-info.u-strasbg.fr> writes:

> Just note that lablgtk (the toplevel) will be linked by all four.
> 
> DO you propose that we have 4different lablgtk toplevels ?
> 
> (Also Jacques (the upstream author) is not favorable to removing the
> gnome and glade part out of lablgtk and in a new package).
> 
> Anyway, this is a post woody issue, i think.

In fact I've more less forgotten that when ocaml link with .cma, it
throw out things that are not needed. So in general the fact that
there is this all in one stuff is not a problem. And it's more
simple. 

The only problem I can see is with the gtkInit module, since some
people might want to not always initialize gtk in some program (as in
a program that can use CLI or GUI depending of what the user want, or
a program that will fork before initialize the gtk thing, one process
using gtk and not the other)

But in such case, someone can use not findlib for gtk. Maybe we could
make some use of predicate, but we may wait for woody release before
bothering with this subtlety.

-- 
Rémi Vanicat
vanicat@labri.u-bordeaux.fr
http://dept-info.labri.u-bordeaux.fr/~vanicat


-- 
To UNSUBSCRIBE, email to debian-ocaml-maint-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: