[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Conflicts when repackaging JACK

Daniel James wrote:
Hi Nick,

I think these are the pertinent lines:

 libjack0.100.0-0 depends on libjack0 (>= 0.109.2-3mlrepo1); however:
  Version of libjack0 on system is 0.109.2-2mepcom1.

 libjack-dev depends on libjack0 (= 0.109.2-3mlrepo1); however:
  Version of libjack0 on system is 0.109.2-2mepcom1.

There's a slight version mismatch there. The system is looking for the package suffix 2-3mlrepo1 but it's finding the suffix 2-2mepcom1.



Hello Daniel,

Thanks for your reply! I see what you mean. However, the new package with the suffix 2-3mlrepo1 is supposed to be installed by the same dpkg process. The problem is that the new libjack0 refuses to install over the old packages without being forced. In these lines:

dpkg: regarding jackd_0.109.2-3mlrepo1_i386.deb containing jackd:
 libjack0 conflicts with jackd (>> 0.109.2-2mepcom1)
  jackd (version 0.109.2-3mlrepo1) is to be installed.
dpkg: error processing jackd_0.109.2-3mlrepo1_i386.deb (--install):
 conflicting packages - not installing jackd
dpkg: regarding libjack0_0.109.2-3mlrepo1_i386.deb containing libjack0:
 libjack0 conflicts with jackd (<< 0.109.2-3mlrepo1)
  jackd (version 0.109.2-2mepcom1) is installed.
dpkg: error processing libjack0_0.109.2-3mlrepo1_i386.deb (--install):
 conflicting packages - not installing libjack0

you can see I am trying to install the new libjack0 package as well, but it is refusing to install over the old version. If I use the option --force-all with just the libjack0 package, it will install, and I can then install the rest of the packages without issue. I just don't know how this would translate to a repository. If I have to manually force the package, how will Synaptic et al. deal with it? If Synaptic will make it work properly, than there is no issue. But isn't Synaptic just a front-end to dpkg? Is there something I can edit in the control file to make dpkg realize it has to replace libjack0 first? I tried using the Replace: and Conflicts: lines, putting in the old version (e.g. in the libjack0 Conflicts: section added libjack0 (= 0.109.2-2mepcom1) and added a Replaces: line with the same), but it still did not work properly. I also tried with no version, and adding jackd with and without a version to libjack0's Conlicts and Replaces. I also tried the same things in the jackd section, and none of it worked. Is this only a problem because they are both the same upstream version? The original -2mepcom1 packages installed fine over the stock etch versions using dpkg -i *.deb. The newest one is a newer Debian revision. Again, thank you for your reply, it is much appreciated!


Reply to: