[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems mirroring archive

On Thu, 8 Sep 2016, Leopold Palomo-Avellaneda wrote:
I'm maintaining a non official mirror  (sir.upc.edu/debian) using the ftpsync
script. It have been working for the last two years (?) with a few issues.

Since yesterday morning I'm not able to sync anymore. I have tested several
servers, and the result is the same:

I don't know which servers you have tried, but according to https://www.debian.org/mirror/list-full it doesn't look like the mirror at verdaguer-ftp.cesca.cat is available over rsync. That also explains why you get a timeout when the script tries to connect using rsync:

$ cat rsync-ftpsync.error.0
rsync: failed to connect to verdaguer-ftp.cesca.cat ( Connection
timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(128)

Although I can connect to the machines that I want to mirror.

Connect how? A mirror can be available over e.g. http without being available over rsync.

Some of you could give me some idea, light or whatever to find why the error?

I just tried to connect to the rsync mirror at ftp.at.debian.org (the first one in the list) and it worked. You might try that one or see if you can find another rsync mirror closer to you in the mirror list:


Povl Ole

Reply to: