[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian MIPS on Netgear WNDR3700 (Atheros AR7161 rev 2)

Dmitry Kurochkin wrote:
> Hello.
> I am trying to setup a Debian chroot on Netgear WNDR3700 router with
> OpenWRT.  Unfortunately, I can not get binaries to run.  The only binary
> from debootstrapped chroot I could run is
> /lib/mips-linux-gnu/ld-2.13.so.  But if I try running any binary with it
> (e.g. /lib/mips-linux-gnu/ld-2.13.so /bin/ls), it just hangs without a
> message.  I tried setting debug and verbose environment variables for
> the loader, but it still outputs nothing.  I also tried mipsel
> architecture and libc6 versions from testing and stable, but it does not
> help.
> Can somebody explain me why it fails?

You run a too recent version of OpenWrt and need to recompile and reflash.
See https://forum.openwrt.org/viewtopic.php?id=24553:
"make kernel_menuconfig -> [x] Enable FPU emulation"

Mark Ruvald

View this message in context: http://old.nabble.com/Debian-MIPS-on-Netgear-WNDR3700-%28Atheros-AR7161-rev-2%29-tp32471867p33086840.html
Sent from the debian-mips mailing list archive at Nabble.com.

Reply to: