[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian MIPS on Netgear WNDR3700 (Atheros AR7161 rev 2)


I am trying to setup a Debian chroot on Netgear WNDR3700 router with
OpenWRT.  Unfortunately, I can not get binaries to run.  The only binary
from debootstrapped chroot I could run is
/lib/mips-linux-gnu/ld-2.13.so.  But if I try running any binary with it
(e.g. /lib/mips-linux-gnu/ld-2.13.so /bin/ls), it just hangs without a
message.  I tried setting debug and verbose environment variables for
the loader, but it still outputs nothing.  I also tried mipsel
architecture and libc6 versions from testing and stable, but it does not

Can somebody explain me why it fails?

Below is some info that might help.  Please let me know if you need any
other info or run any tests.


# uname -a
Linux netgate #1 Tue Sep 6 09:58:59 CEST 2011 mips GNU/Linux

# file /bin/busybox
/bin/busybox: ELF 32-bit MSB executable, MIPS, MIPS32 rel2 version 1, dynamically linked (uses shared libs), corrupted section header size

# file /chroot/bin/ls
/chroot/bin/ls: ELF 32-bit MSB executable, MIPS, MIPS-II version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, with unknown capability 0x41000000 = 0xf676e75, with unknown capability 0x10000 = 0x70401, stripped

# cat /proc/cpuinfo
system type		: Atheros AR7161 rev 2
machine			: NETGEAR WNDR3700
processor		: 0
cpu model		: MIPS 24Kc V7.4
BogoMIPS		: 452.19
wait instruction	: yes
microsecond timers	: yes
tlb_entries		: 16
extra interrupt vector	: yes
hardware watchpoint	: yes, count: 4, address/irw mask: [0x0000, 0x0ff8, 0x0ff8, 0x0ff8]
ASEs implemented	: mips16
shadow register sets	: 1
kscratch registers	: 0
core			: 0
VCED exceptions		: not available
VCEI exceptions		: not available

Reply to: