[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can I install Debian on my NanoNote?

Phil Endecott wrote:
I'm going to see if I can debbootstrap [my NanoNote] with its existing OpenWRT-derived kernel first. If anyone has any thoughts about that i.e. issues that I might run into, please let me know. I'll report back if I'm successful.

Are there any debootstrap experts out there?  Here is what I've tried:

On my Debian PC:

# mkfs.ext3 -j -L "microSD" -O dir_index /dev/sda1
# mount /dev/sda1 /mnt/tmp
# apt-get install debootstrap
# debootstrap --foreign --arch=mipsel stable /mnt/tmp
# sync
# umount /mnt/tmp

Then I put the microSD card in the NanoNote and boot, and it gets mounted as /card. I can see its contents which look sane. I believe that I now need to run the debootstrap "second stage". I have tried various things but none has worked so far, e.g.

# /card/debootstrap/debootstrap --second-stage --second-stage-target=/card
/card/debootstrap/debootstrap: .: line 22: can't open '/usr/share/debootstrap/functions'

My guess is that I'm supposed to chroot before I run this, but chroot just hangs:

# chroot /card
chroot: can't execute '/bin/ash': No such file or directory
# chroot /card /bin/sh
<hangs until ctrl-C>
# chroot /card /debootstrap/debootstrap --second-stage
<hangs until ctrl-C>

It seems to hang using 100% CPU.

Some things that I thought might help

# mount -t proc proc /card/proc
# mount -t sysfs sysfs /card/sys

Same behaviour. What should I do with /dev? It seems to be pre-populated with reasonable-looking things.

ps from another terminal shows the chroot'd process running. "chroot /card /bin/touch /foo" can be seen to be running and its /proc entry has the expected root=/card.

Any ideas anyone?

Thanks,  Phil.

Reply to: