[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A few questions about lenny on Qube2



Hi chaps,

I'm still playing at this here.  So far I've set DMA off and upgraded to 
cobalt_2.6.30~rc8 kernel that Martin posted not too long back.

So currently it's running configure for the postgres source, and I think what's happening is that it's not crashing but going "lazy" - if thats the right term. Could this be something to do with CFS? Or could it be some other fault?  I guess I should try 2.6.22 at some point too should I?

I find it hard to describe what's going off, but here's what seems to be happening right now;

- I start 2 ssh sessions and in one start configure for postgres source, in the other I just started top.

- And for a while all seems fine; configure ticks away and top refreshes every second.

- Then top stops ticking over - but it'll refresh with a keypress. Anyway I exit top and try to run it again... nothing. I hit ctrl-c and try again... nothing.

- The configure script is still ticking over slowly.

- I try "ps ax" - it works; so I try it again... nothing.

- I try "ipcs" and "lsof" they both work.

- I try "ps ax" again... nothing. I hit ctrl-c and now it doesn't come back to the command prompt for a while.. say 5 minutes and eventually it's back.

- It's still going. Some commands still work, some just do nothing. proc/meminfo shows it's not eaten all the memory.

- If I try to start another ssh session I can log in, I get the motd, but I don't get to the shell - I guess I will eventually if I wait.

- I'm not sure what's going off with the configure script now, I can't do much or try and attach to it with strace.

It's just confusing.  Anyone have any ideas what I should look at?

Thanks
Glyn

--- On Sat, 6/6/09, Glyn Astill <glynastill@yahoo.co.uk> wrote:

> From: Glyn Astill <glynastill@yahoo.co.uk>
> Subject: Re: A few questions about lenny on Qube2
> To: "Martin Michlmayr" <tbm@cyrius.com>
> Cc: debian-mips@lists.debian.org
> Date: Saturday, 6 June, 2009, 12:37 PM
> 
> --- On Sat, 6/6/09, Martin Michlmayr <tbm@cyrius.com>
> wrote:
> > 
> > There were some reports about stability problems (but
> > mostly after an
> > etch -> lenny upgrade) but they never got tracked
> > down.  On the other
> > hand, it seems to work fine for a number of folks.
> > 
> 
> I've just tried turning off DMA, but still it dies.
> 
> It's rather strange though, not like last year (on etch) I
> tried when it'd fall over under load, now it seems to not
> die, but just go braindamaged even when there's very little
> happening. 
> 
> For example, doing an apt-get upgrade - halfway through it
> appears to stop doing anything. Hit ctrl-c and I'm back to
> the prompt again, I can try again and I'll sometimes get
> further,sometimes not as far.
> 
> Seems to be the same for anything too, it'll do similar
> with wget or top. 
> 
> Tonight I'll do something and attach strace to it, to see
> if it really is doing nothing. But I'm starting to think
> this qube is going back in the cupboard until my next netbsd
> upgrade/swap :-(
> 
> Glyn
> 






Reply to: