[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on Cobalt RaQ1 working again

On Sun, Feb 24, 2008 at 04:02:56PM +0100, Karsten Merker wrote:

> I have also tried the current d-i daily build,
> http://people.debian.org/~ths/d-i/mipsel/images/2008-02-23/cobalt/nfsroot.tar.gz.
> With this image, the kernel boots, but the system hangs after
> mounting the rootfs from the initrd:

> NET: Registered protocol family 1
> NET: Registered protocol family 17
> rtc_cmos rtc_cmos: setting the system clock to 2008-02-24 14:36:48 (1203863808)
> RAMDISK: Compressed image found at block 0
> VFS: Mounted root (cramfs filesystem) readonly.
> --> hanging forever
> The same daily build works ok on a NASRaQ (which is RaQ2-based).

I have tried copying the initrd contents into a new initrd image
(with an ext2 fs in this case) and adding an 'echo "/sbin/init started"' at
the beginning of /sbin/init.

On the RaQ1 I do not get any output while on the NASRaQ the echo
works as expected. So it seems that /sbin/init is either not
called at all or busybox dies before executing the script.

Gem. Par. 28 Abs. 4 Bundesdatenschutzgesetz widerspreche ich der Nutzung
sowie der Weitergabe meiner personenbezogenen Daten für Zwecke der
Werbung sowie der Markt- oder Meinungsforschung.

Reply to: