[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Confused about mips integer types



Richard B. Kreckel wrote:
> Julien BLACHE wrote:
>> "Richard B. Kreckel" <kreckel@ginac.de> wrote:
>>>> The buildd is probably running a 64bit kernel, so the build system
>>>> attempts to build a 64bit binary; MIPS/MIPSel use a 32bit userland in
>>>> Debian (with a 64bit kernel on most if not all MIPS platforms).
>>> Is configure correct defining __mips64__, then?
>> No, because the userland is 32bit.
>
> Okay, good.

FWIW, I did a test build on mips, which worked fine. I ran the build
under "linux32", which changes the kernel personality (an thus uname
from mips64 to mips).

>>                                    But the check in configure might be
>> a bit too simple-minded to know that... So you'll have to help it
>> somehow.
>> (disclaimer: haven't looked at the actual configure script)
>
> It is just relying on config.guess. But I see now that the version of 
> config.guess and config.sub in the package are from 2003. I'll update them 
> and try again. Thanks a lot so far!

Additionally you may need to pass dpkg-architecture's DEB_HOST_GNU_TYPE
as target to configure.


Thiemo



Reply to: