[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mipsel/Sid Broken on DS5K/2x0?

On Mon, Nov 18, 2002 at 12:18:22AM +0000, The Fungi wrote:
> Given that it's been a few days I'm going to have a go at upgrading
> again. We'll see if i get a different result now and if so I'll look
> deeper into the issue.

So after changing sources.list to use the unstable repositories
(previously using testing with no problem) and doing a dist-upgrade
I get this:

   (Reading database ... 17788 files and directories currently installed.)
   Preparing to replace libc6-dev 2.2.5-14.3 (using .../libc6-dev_2.3.1-3_mipsel.deb) ...
   Unpacking replacement libc6-dev ...
   Preparing to replace debconf 1.2.14 (using .../debconf_1.2.16_all.deb) ...
   Unpacking replacement debconf ...
   Preparing to replace locales 2.2.5-14.3 (using .../locales_2.3.1-3_all.deb) ...
   Unpacking replacement locales ...
   Preparing to replace libc6 2.2.5-14.3 (using .../libc6_2.3.1-3_mipsel.deb) ...
   Unpacking replacement libc6 ...
   dpkg: error processing /var/cache/apt/archives/libc6_2.3.1-3_mipsel.deb (--unpack):
    dpkg: warning - old post-removal script killed by signal (Illegal instruction)

   dpkg: error while cleaning up:
    subprocess pre-installation script killed by signal (Illegal instruction)
   Errors were encountered while processing:
   E: Sub-process /usr/bin/dpkg returned an error code (1)

The above was upgrading from a clean, current sarge to sid. Exactly
the same result as I got last week. Tried installing sid directly,
installing sarge and upgrading to sid, installing woody and
upgrading to sid. Same every time.

Manually running '/var/lib/dpkg/info/libc6.postrm remove' doesn't
produce any errors on my tty but 'apt-get install --reinstall libc6'
after that continues to produce the same errors as before. Needless
to say I am reluctant to leave libc6 in iHR state on one of the
machines in my build farm. Is anyone else aware of a problem in the
upgrade path from libc6 2.2.5-14.3 to 2.3.1-3 on mipsel? Could this
be a problem specific to my hardware? What can I do to test this
more thoroughly? The libc6.postrm from 2.2.5-14.3 is pretty simple.
{ IRL(Jeremy_Stanley); PGP(9E8DFF2E4F5995F8FEADDC5829ABF7441FB84657);
SMTP(fungi@yuggoth.org); IRC(fungi@irc.yuggoth.org#ccl); ICQ(114362511);
AIM(dreadazathoth); YAHOO(crawlingchaoslabs); FINGER(fungi@yuggoth.org);
MUD(Nergel@srmud.net:2325); WWW(http://fungi.yuggoth.org/); }

Reply to: