[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: c++ problems - konqueror, etc.

On Wed, Oct 23, 2002 at 12:06:26PM +0200, Guido Guenther wrote:
>On Tue, Oct 22, 2002 at 09:58:34PM -0400, paul j botelho wrote:
>> If there is no set time table for this, then perhaps those with a better 
>> understanding can let me know what needs to be recompiled.  I am 
>> primarily concerned with getting a web browser (konqueror) running.  I 
>> realize that qt as well as konqueror would need to be recompiled, but 
>> should libc6 also be recompiled?
>The C++ ABI has changed from gcc 2.94.4 to gcc 3.2 in an incompatible
>way, so all libraries using C++ (that konqueror depends on) must be
>recompiled. C only libraries (like glibc) don't need to be recompiled.
>Have a look at the debian-kde list, there is some discussion about KDE3
>and gcc-3.2.

What about big C++ progs like Mozilla, are they running with gcc-3.2.x
on MIPS?

  .''`.    Jan-Hendrik Palic     |
 : :' : ** Debian GNU/ Linux **  |   ** OpenOffice.org **       ,.. ,..
 `. `'   http://www.debian.org   | http://www.openoffice.org  ,: ..`   `
   `-  jan.palic@linux-debian.de |                           '  `  `

Attachment: pgpbkN1SVvoPi.pgp
Description: PGP signature

Reply to: