[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tftp booting off a RH box?

Hash: SHA1

Jan-Hendrik Palic wrote:
| Hi ..
| On Mon, Jun 10, 2002 at 09:11:02PM +1000, vik wrote:
|>| ...more specifically, the booter is complaining:
|>| "Unable to load scsi(0)disk(1)rdisk(0)partition(0)/linux: no
|>| recognizable filesystem on device
|>If u r using the SGI partitioning system/volumes/headers/whatever u call
|>~ it then u probably want scsi(0)disk(1)rdisk(0)partition(8) as ur
|>SystemPartition. note the 8 as the partition. worked for me.
| The volume-header (volhdr) is always the 9th partion on the harddiskt,
| (for Linux). It is the same an the 8th partition for the Indy. So
| scsi(0)disk(x)rdisk(0)partition(0) has always be
| scsi(0)disk(x)rdisk(0)partition(8), where x is your disk-id from the
| disk, where the kernel for booting is saved...

I think fdisk refers to partitions starting from 1, while the PROM
refers to them starting from 0. so partition(8) == /dev/sda9

I had an interesting problem on this note when I was installing debian
on my indy yesterday; the volume header partition was too small (2Mb) to
install the kernel, so I had to remove all the partitions and make it
bigger; problem was after I remove the partitions (including 9 and 11),
fdisk thought my hard disk was about 6 Mb. I ended up running:
dd if=/dev/zero of=/dev/sda
then running fdisk in expert mode to create new SGI disklabels etc and
it worked fine.

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


To UNSUBSCRIBE, email to debian-mips-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: