[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dvhtool minor woes

On Fri, Jan 25, 2002 at 05:29:45PM +0000, Fred Barnes wrote:
> I've been setting up debian MIPS on my indy.  It previously had
> irix installed (until I blasted the partition table types and fsck'd
> /dev/sda1).  When it came to doing the dvhtool thing to put the kernel
> image in the volume header, it failed with a "no room in vh" error.
> Mostly OK, since there's an old IRIX thingie in there which I
> no longer need/want, but how to delete it ?  I tried putting the
> kernel in under the same name as the SGI thing, "sgilabel" iirc,
> but still disagreed.  I think there was "ide" and "sash" in there
> as well, which are sort of no longer needed either, i guess (having
> sash might be useful tho, saves having to plug in that scsi cd-rom..).

I saw the exact same problem when I tried to install woody/sid on
my indy.  I talked to someone about the problem, and he suggested
that I run dd if=/dev/zero of=/dev/sda to basically wipe the
whole drive and then let Debian's fdisk write a new sgi disklabel
in its "expert" mode, then do partitioning as usual.

This allowed me to use dvhtool successfully.  After you do that,
you'll want to setenv OSLoadPartition /dev/sda1 in your prom, so
Linux can boot without needing attendance.  Without that you'd
have to specify 'linux root=/dev/sda1' in the prom, which sucks.

Good luck.

Reply to: