[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mips build environment

Florian Lohoff writes:
 > On Tue, Dec 12, 2000 at 10:20:58AM +0100, Christoph Martin wrote:
 > > 
 > > I tried that, but bash needs libncurses5 which is not in the archive
 > > on master yet.
 > > 
 > > I am trying to build it myself now in the old environment but with the
 > > gcc and binutils version 20001007 from rfc822.org. Hopefully this will
 > > help to go into the chroot environment.
 > If compiling against glibc 2.0.6 you are ablke to use egcs 1.0.3a
 > + binutils 2.8.1 which are simpler :)
 > Gcc 20001007 + binutils same age are known to have some problems
 > nobody seemes to have fixed now...

Well I wanted to build glibc 2.2 binaries. And I need the newer gcc
for that, don't I?

I tried to setup the chroot environment and even cannot start bash. I
unpackaged libc6_2.1.95-1.1.deb, bash_2.04-7.deb,
libreadline4_4.1-2.deb and tried to build libncurses5. But bash just
crashes. Other binaries like locale are working:

#chroot /new/ /usr/bin/locale

#chroot /new/ /bin/bash
Segmentation fault

#chroot /new/ /bin/bash --help
GNU bash, version 2.04.0(1)-release-(mips-mips-linux-gnu)

So I suppose something is wrong with libncurses5.

How did you get the chroot environment for glibc2.2 with bash working?


Reply to: