[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I got me a mips :)

On Wed, Apr 05, 2000 at 06:17:14PM +0200, Wichert Akkerman wrote:
> I got my hands on a SGI indy R4600 machine and I've been playing a
> bit with it. I have a reasonably working RH5.1 environment on it
> and I've been trying to convert that to a Debian system with the
> mips packages on ftp.rfc822.org. Unfortunately it's not really working;
> ext2fs has decided that everything I install is actually a filesystem
> error, and the perl package seems to be very good at giving an
> invalid exception :(
> Can someone bring me up to date on the status of the mips stuff?

Hmm - There are mips and mipsel - Mipsel progress is very far - I have
build ~1050 Packages (Binary) but still lacking xfree, perl, etc 
(I have a hacked perl version) - I have something i call 
"Brute Force Builder" which is something very primitiv (2 Shell scripts)
but does a good job in just keeping the machine busy compiling every package.

I would like to start uploading packages which is not that easy for 2 reasons:

- I am not a Maintainer ( Tried to get maintainer when queue was closed )
- There is no sid/binary-mipsel

With "mips" its a bit more complicated Guido Guenther has set up an
autobuilder on Monday and tries to build packages. I would like to
step in any use my experiences on mipsel to do something - I have an
"SGI Indigo2 Solid Impact" (R4400@250Mhz) which currently does nothing
because i have no working kernel (Mostly console problems). I am doing
currently more Kernel hacking than porting as i first need a kernel :)

Thats the state - Most of the current problems as very essential things

- Kernel (Broken Architectures like SGI_IP22, Broken headers etc)
- Development Toolchain (egcs 1.0.3a + binutils 2.8.1 are OLD)
- No glibc 2.1 (Symbol versioning problems - No support in binutils 
                and different other problems with Incompatibility of MIPS ABI
		and glibc behaviour - Probably glib2.2 will be mips ready)
- No XFree - I tried building XFree 4 which works with little config
             script patches - But doesnt build an X Server - I am now going
	     to compile against those libs and headers and wait for
	     branden to release packages ill take a look at.

Hope this helps a bit further. There is currently no "base.tgz" - Neither
for mipsel nor for mips as essential tools dont build (I hope ill have
tex tonight that i can build e2fsprogs out of the box).

I contacted the perl5-5.005 maintainer if he would like to build his
package on mipsel as i am not a perl guru and it just fails for some
reason i cant see.

Florian Lohoff		flo@rfc822.org		      	+49-subject-2-change
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

Reply to: