[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#687564: RFS: irstlm/5.80.01-1 -- [ITP] IRST Language Modeling Toolkit

Il 01/01/2013 23:21, Jakub Wilk ha scritto:
> * Giulio Paci <giuliopaci@gmail.com>, 2013-01-01, 16:29:
>>> Where is the source for the scripts/other/astyle_* binaries?
>> They are not included neither in the tarball, neither in the upstream repository.
>> Those files are not used, so I will ask upstream to remove them from future releases. In the meanwhile I repackaged the tarball without the scripts/other directory, I
>> added a get-orig-source target to debian/rules and updated watch file accordingly.
> Unfortunately, get-orig-source doesn't work here:
> $ ./debian/rules get-orig-source
> debian/rules:61: warning: overriding recipe for target `get-orig-source'
> /usr/share/cdbs/1/rules/upstream-tarball.mk:86: warning: ignoring old recipe for target `get-orig-source'
> mkdir -p /temporary
> mkdir: cannot create directory `/temporary': Permission denied
> make: *** [get-orig-source] Error 1

On my system it happened a weird thing: I tried to run the same command as you and everything worked fine.
So I checked if there was a new cdbs version, I updated it and then I was able to reproduce the error.
Finally I reinstalled the same cdbs version that I had before, but the get-orig-source target was not working anymore.

Do you have any idea about why it worked and then stopped to work?

In the meanwhile I fixed the problem: I missed DEB_ROOT declaration in the rules file, so I am very surprised that it worked on my system.


Reply to: