[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#663455: RFS: m2m-aligner/1.0-1 [ITP] -- many-to-many alignments for string transduction

Il 31/12/2012 20:54, Jakub Wilk ha scritto:
> For the record, the source package is currently at:
> http://mentors.debian.net/debian/pool/main/m/m2m-aligner/m2m-aligner_1.1-1.dsc
> Lintian emits:
> W: m2m-aligner source: out-of-date-standards-version 3.9.3 (current is 3.9.4)

Fixed, but not uploaded yet.

> tclap1.1.0/ looks like an embedded copy of a library, which is packaged in Debian separately. Please build-depend on libtclap-dev and make sure that the embedded copy won't
> be used at build time.

m2m-aligner fails to build with tclap 1.2.0. I found a workaround, but not a proper fix. So I contacted the upstream author about it.

> I wouldn't call the "You are welcome to use the code for research, commercial, and other purposes" statement a license; I don't think it belongs in debian/copyright. On the
> other hand, I don't see the MIT license (which is mentioned on the homepage) anywhere in the upstream tarball...

I also asked for a new release with an explicit license included in the tarball.

> Why do you build-depend on "libstdc++6-4.6-dev | libstdc++-dev" explicitly? The C++ standard library is guaranteed to be (transitively) build-essential.

There is no reason. It was just that I did not know about it when I packaged m2m-aligner and then I forgot to fix it later.
Fixed, but not uploaded yet.

I will let you know when I will hear from upstream.


Reply to: