[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#690049: RFS: sylkserver/2.1.1-1

(I don't intend to sponsor this package.)

* Daniel Pocock <daniel@pocock.com.au>, 2012-10-09, 15:45:

Lintian emits:

P: sylkserver: no-upstream-changelog
P: sylkserver-sounds: no-upstream-changelog
I: sylkserver: init.d-script-does-not-implement-optional-option etc/init.d/sylkserver status

Furthermore, lintian4python emits:

i: sylkserver source: debian-pycompat-is-obsolete

I'd use "debhelper (>= 8)" instead of "debhelper (>= 8.0.0)".

Current standards versions is 3.9.4.

The versioned build-dependency on python is insufficient; as per dh_python2 manpage it should be at least >= 2.6.6-3~.

The copyright file is not policy-compliant. Please see:

Are the Python modules this package includes supposed to be used by other software? If yes, then the package name should be python-sylk (or at the very least it should provide virtual package with such name). Otherwise, please move them into a private directory.

The binary package depend on non-existent packages:
- python-backports
- python-eventlet-0.8
- python-sipsimple

I see there's ITP for the last one (#689510); no RFS, though.

Jakub Wilk

Reply to: