[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#689500: RFS: python-eventlib/0.1.0-1

On 03/10/12 22:06, Jakub Wilk wrote:
> (I don't intend to sponsor this package.)

Thanks for the feedback, I'll respond to some of the points, some I'm
deferring to upstream (Saúl and AG Projects) as they are interested in
becoming more involved with the Debian packaging

This package and the related packages are based on artifacts created by
upstream for their unofficial Debian packages.  I have done some basic
adaption (e.g. to DEP-5 copyright), but otherwise I have used the
material from upstream.

> * Daniel Pocock <daniel@pocock.com.au>, 2012-10-03, 12:23:
>> http://mentors.debian.net/debian/pool/main/p/python-eventlib/python-eventlib_0.1.0-1.dsc
> lintian reports:
> I: python-eventlib source: debian-watch-file-is-missing

Fixed that one yesterday

> P: python-eventlib: no-upstream-changelog
> I: python-eventlib: description-synopsis-might-not-be-phrased-properly
> Furthermore, lintian4python reports:
> i: python-eventlib source: debian-pycompat-is-obsolete
> e: python-eventlib: except-shadows-builtin
> usr/share/pyshared/eventlib/db_pool.py:175: ValueError
> e: python-eventlib: except-shadows-builtin
> usr/share/pyshared/eventlib/httpd.py:497: ValueError
> e: python-eventlib: string-exception
> usr/share/pyshared/eventlib/saranwrap.py:654
> (+ a bunch of pyflakes-* tags, most of which are likely either false
> positives or not worth caring.)
> The copyright file is not policy-compliant. Please see:
> https://lists.debian.org/debian-devel-announce/2006/03/msg00023.html
> Worse, it doesn't seem to be factually correct either. It says "LGPL-2",
> whereas e.g. setup.py says "MIT License".

I've previously made mistakes with DEP-5 and lintian has identified them

As for the LGPL-2 or MIT - the upstream tarball contains a
debian/copyright referring to LGPL-2.  So I leave it to them to have the
final say on which they prefer.

> I'd use "debhelper (>= 8)" instead of "debhelper (>= 8.0.0)".
> The versioned build-dependency on python-all is insufficent; as per
> dh_python2 manpage it should be at least >= 2.6.6-3~.
> Current standards version is 3.9.4.
> What is the purpose of "Conflicts: python-eventlet"?

python-eventlib is a fork of python-eventlet

upstream can clarify the need for the Conflicts header.

> Out of curiosity, why do you remove dist and MANIFEST in the clean target?
> Upstream seems to provide a test suite. Please run it at build time.

I leave these for upstream comments

> Upstream provides some examples. It might be worth including the in the 
> binary package.

Reply to: