[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: blogofile (2nd try)

* Andreas Rütten <AndreasRuetten@gmx.de>, 2011-11-27, 22:37:

dget -x http://mentors.debian.net/debian/pool/main/b/blogofile/blogofile_0.7.1-1.dsc

(I don't intend to sponsor this package.)

The binary package depend on: "python-textile, python-markdown, …, python-docutils". Do I really need _all_ of them? Normally you write a blog only in one markup language…

The argparse module is included in the standards library since 2.7, so the dependency on "python-argparse" could be "python (>= 2.7) | python-argparse".

Are the Python modules that you ship in the binary package supposed to be used by other packages (than those built from this source package)? If yes, then the package name should be python-blogofile. Otherwise, please move them into a private directory.

blogofile doesn't start in a minimal chroot:
| $ blogofile
| Traceback (most recent call last):
|   File "/usr/bin/blogofile", line 5, in <module>
|     from pkg_resources import load_entry_point
| ImportError: No module named pkg_resources

Perhaps it's a missing dependency on python-pkg-resources?

In debian/rules, you could replace "-exec rm -f {} \;" with "-delete".

Upstream provides a test suite, please run it at build time (ideally, using all supported Python versions).

In a few places I saw code like this:
|        try:
|            do_something()
|        except:
|            pass

This is bad, because "except:" with catch also e.g. KeyboardInterrupt.

What is blogofile.util.html_escape for? It doesn't seem to be used by anything. (Also doesn't look particularly efficient. :P)

Please use "X-Python-Version: >= 2.6" instead of "X-Python-Version: 2.6, 2.7".

I wonder if a single script of 200 lines really warrants a separate binary package...

But anyway, to be pedantically correct, blogofile-converters's dependency on python should be "python (>= 2.6)", since the script uses 2.6 features.

Jakub Wilk

Reply to: