[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: mail-notification (updated package; NMU for RC bugs among others)

Hi Michael,

On Wed, 07 Sep 2011 02:43:37 +0200, Michael Biebl <biebl@debian.org> wrote:
> Am 07.09.2011 00:57, schrieb Stephen Kitt:
> > I am looking for a sponsor for the package "mail-notification". This
> > update would fix a couple of RC bugs (the usual Evolution updates,
> > which also require a switch to GTK+ 3);
> Hm, the package still build-depends on libgtk2.0-dev, is that an oversight?

It's only needed for gtk-builder-convert; I suppose I could just provide
the .ui files in a patch, but I'd rather build everything from the original
sources as far as possible.

> Also, the package seem to still use a lot of deprecated GNOME 2 libs, 
> like libgnomeprintui2.2-dev, libgnomevfs2-dev and libgnome2-dev.
> Are they still required? If so, you should consider porting them to the 
> newer interfaces, like GVFS.

OK - do you have any pointers to migration documentation? The main intent of
the NMU was to fix the FTBFS, not really overhaul the whole package, but it
would indeed be better to avoid leaving predictable future FTBFSes...

Thanks for looking at the package,


Reply to: