[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: libchart-php

Hi Daniel,

Daniel Lombraña González wrote:
> I am looking for a sponsor for my package "libchart-php".
> * Package name    : libchart-php
>   Version         : 1.2.2
>   Upstream Author : [fill in name and email of upstream]
> * URL             : http://code.google.com/p/libchart/
> * License         : GPLv3
>   Section         : web
> It builds these binary packages:
> libchart-php - PHP library for creating charts.
> The package appears to be lintian clean.

Lintian reports a few issues that you should address:

  W: libchart-php source: out-of-date-standards-version 3.8.0 (current is 3.9.1)
  I: libchart-php: description-synopsis-might-not-be-phrased-properly
  I: libchart-php: extended-description-is-probably-too-short

Also, you should use a version number in the form
${upstream_version}-${debian_version} (i.e. 1.2.2-1).

And your debian/changelog entry is incomplete, you should have a bug
number in the "(Closes: #nnnn)" part (submit a bug against wnpp if you
didn't already, see http://www.debian.org/devel/wnpp/ ).


Benoît Knecht

Reply to: