[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: wicd-client-kde

On Mon, 1 Nov 2010 11:30:07 +0100
Iker Salmón San Millán <shaola@esdebian.org> wrote:

> Dear Mentors,
> I am looking for a sponsor for my package "wicd-client-kde".
> * Package name    : wicd-client-kde
>   Version         : 0.2.1-1
>   Upstream Author : Anthony Vital <yesmichel@gmail.com>
> * URL             : http://gitorious.org/wicd-client-kde
> * License         : GPL v3
>   Section         : kde
> It builds these binary packages:
> wicd-client-kde - wired and wireless network manager - KDE client
> The package appears to be lintian clean.
> The upload would fix these bugs: 602049
> My motivation for maintaining this package is:
> I am using this program since the first releases and works quite well.  I
> also want to start mantaining some packages and i think this package is a
> good start for it.
> I am in contact with the upstream author and he also would be glad to have
> his program in debian oficial repositories and he is going to help me fixing
> posibles bugs if appear.
> The package can be found on mentors.debian.net:
> - URL: http://mentors.debian.net/debian/pool/main/w/wicd-client-kde
> - Source repository: deb-src http://mentors.debian.net/debian unstable main
> contrib non-free
> - dget
> http://mentors.debian.net/debian/pool/main/w/wicd-client-kde/wicd-client-kde_0.2.1-1.dsc
> I would be glad if someone uploaded this package for me.
> Kind regards
>  Iker Salmón San Millán


I am not a DD, so I have no possiblity to upload any package, and I am
not familiar with KDE stuff - but anyway - 

Trying to build (pdebuild) this package I do get a warning for lacking 
cmake_minimum_required, which probably isn't too serious:

---- 8< ----
CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be
lower if you wish to support older CMake versions for this project.
For more information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.
---- 8< ----

What is worse, I get this too:

---- 8< ----
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:58 (MESSAGE):
  ERROR: Could not find KDE4 kde4-config
---- 8< ----

Have you forgotten som build-depends on some KDE development package?

I am very far from an expert on packaging (I am also in the process of
trying to get a package into Debian), but as I understand reviewing of
others packages is encouraged.

best regards
Andreas Rönnquist <gusnan@gusnan.se>

Reply to: