[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: .deb package for a library generation

Hash: SHA256

On 2010-08-08 15:45, Zvi Dubitzky wrote:
> I need to generate a Debian package for a library 
> As an exercise I tried it with   libvirt . 
> I am running a Ubuntu 8.10 . and use the libvirt.0.6.1 tar.gz 


Thanks for your interest in Debian, unfortunately I do not have a lot of
time so this message will be rather brief.

I have added the mail to debian-mentors@l.d.o which is our dedicated
mailing lists for how to do packaging and put you in CC, since I was
unsure whether you would receive the email otherwise.

> For the library package I followed the Ubuntu instructions at  : 
> https://wiki.ubuntu.com/PackagingGuide/Basic
> (I first generated  a .deb for the hello program and it  went ok)
> For the library I did :
> 1.  got the tar of libvirt .  made a copy to orig.tar.gz
> 2. untarred the tared library . cd to the untarred code
> 3.  there ran :  dh_make -e your.maintainer@address . This created the 
> debian directory. Got no bad 
>      commnets    from lintian.
> 4. ran : debuild -S -us -uc  (to avoid gpg for now)
>     That generated the ../*.dsc and ../*.diff.gz  . Looks ok.
> 5. ran: sudo pbuilder build ../*.dsc  ( changed the debian/rules to have 
> ./configure --with-xen=no otherwise
>    it complained about xs_read missing in libxenstore - which exists . 
> libxen3, libxen3-deb are installed ok)
>   But now during the ./confugre run I get the following message :
> .....
> checking for pkg-config... no
> checking libxml2 xml2-config >= 2.5.0 ... configure: error: Could not find 
> libxml2 anywhere (see config.log for details).
> make: *** [config.status] Error 1
> dpkg-buildpackage: failure: debian/rules build gave error exit status 2
> pbuilder: Failed autobuilding of package
>  -> Aborting with an error
>  -> unmounting dev/pts filesystem
>  -> unmounting proc filesystem
>  -> cleaning the build env
> ...
> pkg-config is installed and the newest . libxml2 is installed  and newest 
> (/usr/lib/) and  xml2-config --version gives  2.6.32
> so why does the system complain : Could not find libxml2 anywhere  . BTW: 
> config.log was not generated yet .
> Any idea/ help ?
> thanks
> Zvi Dubitzky 
> Email:dubi@il.ibm.com
> IBM Haifa Research Laboratory    Phone: +972-4-8296182
> Haifa, 31905, ISRAEL 

dh_make cannot deduce every Build-Dependency of your package, which is
likely to be your problem. As I recall (but I have not used it in a
while) it only generate a set of template files to get you started.
  Also pbuilder builds your package in a "clean chroot" where it only
installs the packages listed in Build-Depends and Build-Depends-Indep of
your debian/control (+ the "build-essential" packages).

So you probably have to open the debian/control file and add the correct
build dependencies there.

I apologize for the short answer with no reference to relevant
information, but I am really out of time :)
  I am about to leave DebConf10 (like a lot of other Debian people).


Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: